ReLoad

Thierry Jaouen ~ WikiBlog
"Rien à foutre d'être lu, tant que je peux me relire."

Outils pour utilisateurs

Outils du site


blog:2013:02:05:kimsufi_ovh

Kimsufi chez OVH

Testons l'hebergement “kimsufi” d'OVH.

Intro

Je vais, bien sur, installer une Debian Squeeze 64 bit !

Les buts sont:

  • Découvrir un nouvel hébergeur.
  • Tester l'accès distant en cas de panne (genre, un KVM)
  • Tester le reseau : youtube rame t'il ?
  • Tester XEN

~~READMORE~~

Louons

Choix

64 bit, Virtualisation et un peu de RAM.

Paiement

Un bon point: paypal est accepté, ce qui est toujours appréciable pour découvrir un nouveau service.

Livraison

Par contre, il m'a fallu attendre 6 heures la livraison de “mon” serveur… au lieu des “1 heure” annoncé sur l'encart de publicité.

Quand on découvre un nouveau service, les promesses n'ont tenu sont toujours inquiétantes !!! :-)

Premier accès

Un mot de passe root est envoyé par mail.

Environnement de base

Le bordel

Reseaux

Je constate que plusieurs interfaces réseaux sont montées, mais en dehors de eth0 , je ne sais pas a quoi sert le reste !

tunl0 etc… ????

Pour ipv6 , des routes sont entrés (via post-up), et je ne sais pas pourquoi. (et puis je suis complètement newbie sur le sujet.)

Modules

lsmod me retourne que /proc/modules n'existe pas !?

noyau ovh

A quoi sert ce noyau “ovh” ?

Divers

Locales

D'un autre temps: UTF-8 existe !

Raid

Le Raid 1 est logiciel, avec mdadm.

La racine des home est monté sur md2.

vKVM

Afin d'y voir plus clair, je vais lancer le “KVM”.

Donc, dans la console d'administration, je choisis:

Netboot >> vKVM

Et puis je reboote le serveur.

Je reçois un “e-mail” dans la foulée pour un accès via VNC .

L'accès à VNC ne suffit pas.

Je pointe l'image ISO “Debian Live Rescue”, qui est chez Proxad :

Pour une image “64 bit”, cocher la case “64 bit” .

ftp://ftp.proxad.net/mirrors/cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/debian-live-6.0.6-amd64-rescue.iso

Quelques secondes plus tard, l'écran de boot apparait.

Installer Debian a ma sauce

Toujours a partir du “vKVM”, demarrer avec l'iso “net-install”.

RAID1 (logiciel) + LVM etc…

Problème 1

Sans doute parce que ça fonctionne dans un environnement “qemu” (il me semble), c'est trés lent !

:!: Compter 4 à 5 heures pour l'installation !

Problème 2

Ça plante au moment du reboot final … A priori c'est pas grave..

Problème 3

Pas de réseau: parce que la configuration est faite avec une carte réseau virtuelle, et non pas avec la carte réseau finale.

Pour corriger cela, il faudra redémarrer (toujours avec vKVM) et corriger le fichier /etc/udev/rules.d/70-persistent-net.rules en inversant eth0 et eth1 .

Pour info, ma conf dans /etc/network/interfaces ressemble à ça :

auto eth0
iface eth0 inet static
  address 12.34.56.78
  netmask 255.255.255.0
  gateway 12.34.56.254

#allow-hotplug eth1
#iface eth1 inet dhcp

FIXME ca sert a quoi “eth1” ??? pas certain qu'on demarre dessus avec vKVM!

Problème 4

Grub est un peu dans les choux pour les mêmes raisons que pour le reseau.

Le fichier /boot/grub/device.map fait référence aux disks virtuels (qemu).

Donc, dés que possible, faire:

# grub-mkdevicemap 

Et vérifier le fichier /boot/grub/device.map

Et puis aussi:

# dpkg-reconfigure grub-pc

vKVM et LVM

En cas de pépin, il faut savoir monter les partitions LVM.

rescue iso

Faire pointer le “ftp” sur l'image “live rescue Debian 6”.

RAID

Preparer un point de montage:

# mkdir /mnt/newsys

Monter les partitions “mdadm” :

# mdadm --examine /dev/sda1

Repérer la ligne:

Array UUID : xxxx:xxxx:xxxx:xxxx
# mdadm /dev/md0 --assemble -u xxxx:xxxx:xxxx:xxxx

Idem pour le plus gros:

# mdadm --examine /dev/sda2

… etc..

# mdadm /dev/md1 --assemble -u yyyy:yyyy:yyyy:yyyy

Et là, cat /proc/mdstat me montre que md1 est en train de ce reconstruire… et c'est looooooong!

Mais continuons, puisque c'est un RAID !

LVM

# /etc/init.d/lvm2 start
# pvs 

… retourne bien les partitions lvm

Mountons le systeme:

# mount /dev/vg0/sys /mnt/newsys

Mountons le boot:

# mount /dev/md1 /mnt/newsys/boot

Mountage fait ...

Maintenant, on est sensé pouvoir accéder a l'ensemble du système.

A la fin

Aprés avoir fait ce qu'on avait a faire, avant de rebooter , il faut démounter tout correctement.

# umount /mnt/newsys/boot
# umount /mnt/newsys
# /etc/init.d/lvm2 stop

Et enfin:

# mdadm --stop /dev/md0
# mdadm --stop /dev/md1
:!: Si la reconstruction du RAID est en cours, le stop peut échouer.

Un petit bilan

Tout fonctionne, y compris Xen .

Petit plus: Youtube fonctionne trés bien chez OVH !

blog/2013/02/05/kimsufi_ovh.txt · Dernière modification: 2013/02/05 18:07 par thierry